Compatibility with original TI-Nspire programs:

BlockDude on CX
Programs must be rebuilt with the latest SDK because of several hardware changes on the TI-Nspire CX. The rebuild is not required for classic TI-Nspire models.

Credits to Adriweb for the picture and apcalc for Block Dude Nspire.